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1 Introduction 

Spotxel® Microarray, previously known as Spotxel® Microarray Image and Data Analysis Software, 

provides intuitive and user-friendly tools for microarray image and data analysis. The software 

includes features for microarray image analysis and the automatic processing of multiple microarray 

images. Additionally, it offers tools for replicate processing, data filtering, and data normalization, 

which can significantly enhance the quality of your microarray data. The data mining tools enable 

you to identify key features and samples in your microarray study and explore their relationships. 

This Quick Start Guide offers an overview of basic commands for immediate access to the software’s 

functionalities. For more detailed information, please refer to the User’s Guide. 

1.1 Installation 

The software runs natively on both Windows and Mac OS X platforms. Depending on the installation 

directory, installation of the software may require system administrator rights. 

Windows Platforms 

Spotxel® Microarray is compatible with 64-bit versions of Windows 7, Windows 8, Windows 10, and 

Windows 11. To install the software: 

 Run the installer. 

 If the current Windows account is not an administrator, you will be prompted to input an 

administrative account and password. 

Mac OS X platforms 

The software is compatible with Mac OS X 10.7 and later versions. To install the software: 

 Double-click on the installer to initiate the setup program. 

 Confirm the installation directory when prompted; by default, this is set to 

$HOME/SpotxelMicroarray. 

Once the installation is complete, navigate to the installation folder and click on the Spotxel app to 

launch the software. 

1.2 Product Activation 

After installing the software on Windows, you may want to activate it with a trial serial number. This 

allows you to use premium functionalities such as data quantification, automatic array alignment, 

and batch processing of multiple images. The trial use for the software on Mac OS X platforms is 

automatically managed and does not require this step. 

http://www.sicasys.de/spotxel/help/activation/
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It is important to note the GAL Array Editor module, along with the functionality for handling 

microarray images, is entirely free and become accessible immediately upon software installation, 

with no license required. 

When the free trial period expires, you can purchase a software license for continued use of 

premium functions. Upon purchase, you will receive a serial number to activate the license. 

1.3 Upgrade 

Simply run the installer for the new version to upgrade. The software configuration will be handled 

automatically. You do not need to activate the software again if it has already been activated.  

1.4 Software User Interface 

Associated software controls are grouped in labeled components (Fig. 1). We refer to a software 

component using the name listed in Table 1. 

 

Fig. 1: User Interface. 

Component Component Name 

 
The menu 

 
The canvas toolbar 

 
The main toolbar 

 
The control panel 

 
The canvas 

Table 1: Software Components. 

http://www.sicasys.de/spotxel/pricing/
http://www.sicasys.de/spotxel/help/activation/
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The main toolbar provides quick access to a group of related functions. They are described in Table 2. 

Clicking on a button on the main toolbar opens the control panel for the function group. The 

software displays the data and the analysis results in a sheet on the right of the control panel. 

 

Select image channel.  
Change image’s intensity.  
Rotate images.  

Process replicates, filtering data, 
and normalize data. 

 

Add, edit, rotate and move blocks. 
View and edit spots’ ID and name. 

 

Hierarchical Clustering Analysis:  
Show features and samples on a 
heat map with their correlation.  

 

Quantify the array data and browse 
the quantified data. 

 

Principal Component Analysis:  
Select important features and 
samples. 

 

Batch Processing: 
Automatically process and quantify 
many microarray images. 

  

Table 2: The Main Toolbar and Related Functions. 

1.5 Terms and Concepts 

In this manual, an array is the spot layout plus its annotation. The layout can be stored as either a 

GenePix Array List (GAL) (*.gal) or a PepSlide Designer file (PSF) (*.psf). 

In a microarray assay, binding events at designated spots generate signals when the slide is exposed 

to a sample. These signals are captured by a scanner and converted into a digital array image - a 

matrix of grayscale pixels whose brightness reflects the signal intensity. For enhanced visual 

interpretation, our software maps these grayscale intensities to red or green hues. 

1.5.1 GAL arrays – Spot and Block 

  

Fig. 2: A rectangular block with 6 spots. Fig. 3: A hexagonal grid with 16 spots. 

A spot is represented as a white square (Fig. 2) in a rectangular block, or a white hexagon (Fig. 3) in a 

hexagonal block (also referred to as orange-packing).  

Within each spot, the spotted region is enclosed by the dashed circle, indicating the region where 

true binding is expected. The array composes of blocks. A block is a group of spots located next to 

each other, appearing as a grid of white squares or hexagons. 

Working exclusively with GAL? You can skip ahead to section 1.5.3. 
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1.5.2 PSF arrays – Spot and Spot Family 

A spot is displayed as a white rectangle (Fig. 4). Within each spot, the 

spotted region is enclosed by a dashed rectangle, marking the region of 

interest for quantification.  

A spot family (abbreviated SF) consists of adjacent spots produced from 

the same source. In all analysis steps, an SF functions the same way as a 

block in a GAL array. 

1.5.3 Analysis Workflow (common to GAL & PSF) 

Quantification estimates the true binding signal of each spot, based on statistical measurements of 

the pixel intensities within that spot. 

Array alignment links layout spots to image signals. Because the spot signal is assumed to reflect true 

binding, the software adjusts block or SF positions to maximize alignment between the spotted 

region and the signal. 

2 Microarray Data Analysis Diagram 

 

 

 

Load image (*.tif) 

Load array (*.gal, *.psf) 

Align array 

Quantify array data 

Analyze a single slide manually 

Create and execute a batch  

Process replicates, filter data, and 
normalize data. 

Identify important features and 
samples, and their relationships 

Analyze many slides automatically 

For each slide 

List of quantified data files (*.csv, *.gpr) 

 

Fig. 4: Rectangular Spot 

Fig. 5: The Analysis Diagram. 
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The analysis diagram (Fig. 5) provides a visual summary of the two primary workflows supported by 

the software: 

 Single-slide analysis, covered in Section 3, and 

 Batch processing of multiple slides, detailed in Section 4. 

3 Analyze a Single Slide 

1 

 

Load the Microarray Image and Inspect the Signal 

 Go to Images > Open Image and select the TIFF file of the slide. 

 Assign the image signal to either the Red or Green channel. 

For example, if you assign the signal to the Red channel, the canvas displays red pixels to 

represent signal intensity (Fig. 2). 

 
 

The software supports 8-bit, 16-bit, and 24-bit grayscale TIFF images. For optimal 

quality and performance, use 16-bit grayscale TIFFs. 

1.1 If using two TIFF images or a multi-page TIFF: 

 Assign each image (or each page) to the Red or Green channel. 

 To view individual or combined channels: 

 Open the Images control panel. 

 In the Image Channels section, select Red, Green, or Combined. 

1.2 Adjust the View Scale 

 Use Zoom In and Zoom Out on the canvas toolbar. 

 Or, choose a specific zoom level from the Zoom dropdown. 

1.3 Enhance Signal Visibility 

 Open the Images control panel. 

 In the Image Intensity section: 

 Enter a positive contrast value (e.g., 75), or 

 Select Enhance contrast automatically. 

Alternatively: 

 In the Image Channels section, choose Red or Green, then toggle the Colorize switch 
for better contrast. 

2 

 

Load the Array File (*.gal or *.psf) and View Layout 

 Open the Arrays control panel. 

 Click Open and select the layout file. 

 The white array grid (see Fig. 2 and Fig. 3) is then overlaid on the image in the canvas. 

2.1 View Block and Spot Properties (for GAL arrays) 

 To view block properties: 

 Select the Block tab in the Array File section. 

 Hover over or click a block in the canvas. 

 To view spot properties: 

 Select the Spot tab and hover over or click any spot.  

2.2 View Spot Family and Spot Properties (for PSF arrays) 

 To view spot family properties: 
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 Select the Spot Family tab in the Array File section. 

 Hover over or click an SF in the canvas. 

 To view spot properties: 

 Select the Spot tab and hover over or click any spot. 

3 

 

Align the Array 

 Enhance spot visibility (Refer to Step 1.3.) 

 Assess the spot pattern. Use control spots to judge whether rotation or block (SF) 

repositioning is needed. 

 Save the alignment. 

If signal quality is sufficient, you can attempt automatic alignment. Otherwise, follow 

Step 3.3 to align the array manually. 

 
 

Tip: Always back up the original array file. For each image, use Arrays > Save Array 

As to create and align a copy. 

3.1 Rotate the Image 

 In the Image Rotation section: 

 Flip horizontally or vertically. 

 Rotate by 90°, 180°, or 270°. 

3.2 Align the Array Automatically 

 In the Array File section, click Align. 

3.3 Reposition Blocks and Spot Families 

For GAL arrays 

 Open Arrays > Block tab.  

 Select blocks individually (Ctrl + Click) or all blocks (Ctrl + A). 

 Drag blocks to align the dashed circle with the signal (shown in red, green, or another 

non-white color; see Fig. 2 and Fig. 3). 

For PSF arrays 

 Open Arrays > Spot Family. 

 Select and drag spot families (SFs) the same way as blocks. 

3.4 Save the Alignment 

 Use the Arrays > Save Array menu to overwrite the current file, or 

 Use Save Array As to store it in a new GAL file. 

4 

 

Quantify the Array Data 

 Ensure alignment. Confirm that the array is correctly aligned with the image. 

 Open the Data Quantification control panel. 

 Click Quantify Array. 

 Once complete, the quantified data table is updated - each row shows 

intensity values for a spot. 

 To identify spots of interest, consider using intensity values such as Red F. 

Mean, Red F. Median, Green F. Mean, or Green F. Median. 

4.1 View Quantified Data 

 Click a spot in the canvas to highlight its row in the data table. 

 Select a row in the table to highlight the corresponding spot in the image. 
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 Use the navigation keys (Up, Down, Page Up, Page Down) to browse data 

interactively. 

4.2 Save Quantification Results 

Export data: 

 In the Data Export widget, click CSV or GPR to save the quantified data to a .csv or 

.gpr file. 

 If the widget is not visible, enable it via View > Data Export. 

Save the project: 

 Go to Project > Save Project to store the full analysis in a Spotxel project file 

(*.spotxelproj). 

The project file (e.g., s1.spotxelproj) keeps links to the image, aligned array, and 

quantified data. Reopen it via Project > Open Project to resume the analysis at any time. 

4 Analyze many slides automatically 

In high-throughput studies, you may need to screen a microarray with N samples using N slides. 

These slides share the same layout annotation - known as the template array - which can be either: 

 a GenePix Array List (*.gal), or 

 a PepSlide Designer file (*.psf). 

Processing generates N grayscale TIFF images, one for each slide. You can create and run a batch to 

automatically analyze all N images and extract their quantified data. 

Tip: Ensure each image has sufficient spot signal for automatic array alignment. 

1 

 

Create and Execute the Batch 

 Click the Batch button on the main toolbar. 

 In the Batch Scheduler control panel, specify the images, the template array, and 

processing options.

 Click the Run button to execute the batch.

1.1 Specify Parameters and Options 

 Click Add and select the images to process. 

 In Template Array (applied to all images) 

 Click Browse and select the .gal or .psf file. 

 In Where should generated files be stored? 

 use the default (image's folder), or  

 Click Browse to choose a custom location. 

 If rotation is needed: 

 Click Rotate Images and choose Flip and/or Rotate (90°, 180°, or 270°). 

 To save the batch setup: 

 Go to Batch > Save Batch. 

 A log file will be created automatically with the same name. 
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Tip: Use a separate folder for each batch to keep files organized. 

1.2 Execute the Batch 

 Click Run to begin processing. 

 The status of each image will update live as it is processed. 

For an input file like sample001.tif, the following output files are generated: 

 sample001.gal or sample001.psf: array file linking layout to signal in the image 

 sample001.csv: quantified data in CSV format 

 sample001.gpr:  quantified data in GenePix Result format 

 sample001.spotxelproj: project file containing full analysis results 

Running the batch for N images will generate N .spotxelproj files for downstream 

analysis. 

 


